Написать программу находящую сумму всех трехзначных чисел, в записи которых есть четные...

0 голосов
76 просмотров

Написать программу находящую сумму всех трехзначных чисел, в записи которых есть четные цифры


Информатика (17 баллов) | 76 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var a,b,c,d,j:integer;
begin
j:=0;
for a:=100 to 112 do
begin
b:=a div 10;
d:=a mod 10;
c:=a-(100*b)-d;
if (a div 2=a/2) or (b div 2=b/2) or (c div 2=c/2) then j:=j+1;
end;
writeln(j);
end.

это для pascalABC 

 
(5.2k баллов)
0 голосов

Program n1;
Uses CRT;
Var a,b,c,s,i: integer;
begin
ClrScr;
For i:=100 to 999 do
begin
a:=i div 100;
b:=i mod 100 div 10;
c:=i mod 10;
If (a mod 2=0)or(b mod 2=0)or(c mod 2=0) then s:=s+i;
end;
writeln('summa ravna ',s);
readln
end.

(1.7k баллов)