напишите программу которая получает возраст человека и выводит его возраст со словами:...

0 голосов
118 просмотров

напишите программу которая получает возраст человека и выводит его возраст со словами: год,года или лет??))помогите,очень нужно) но программа должна быть простая,так как я учусь в соц.гуме)


Информатика (24 баллов) | 118 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
 n:integer;
begin
 readln(n);
 if (n mod 10 = 1) and ((n mod 100) div 10<>1) then
  writeln(n,' год')
 else
  if ((n mod 10 = 2) or (n mod 10 = 3) or (n mod 10 = 4)) and ((n mod 100) div 10<>1) then
   writeln(n,' года')
  else
   writeln(n,' лет');
end.

(517 баллов)
0

Спасибо большое,DmitryINF))