Задача по информатикеНапишите программу, которая в последовательности натуральных чисел...

0 голосов
199 просмотров
Задача по информатике
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число, оканчивающееся на 4.

Информатика (14 баллов) | 199 просмотров
0
0

ну ды ладно, что ввести?

0

агась

0

прошу прощения(

0

я рад

0

все супер

0

попробую

0

lol, вот какое количество ввел - столько чисел и пиши через enter

0

ну я то зашел и ввел, один раз количество чисел, второй раз число numb и она ничего не выводит.

Дан 1 ответ
0 голосов

Вот держи)

var k,N,numb,min :integer;
begin
min:=30000;
readln(N);
for k:= 1 to N do 
begin
readln(numb);
if (numb mod 10 = 4) and (numb < min) then 
min:= numb;
end;
writeln(min);
end.


image
(800 баллов)
0

да

0

Так что не надо)

0

И другую ты тоже решал)

0

Не та

0

Ой

0

выше посмотри)

0

так я её уже решал же

0

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число, оканчивающееся на 4.

0

А можешь мне помочь?

0

обращайся, если что) с паскалем мне нравится работать ))