Напишите программу, которая по введённым с клавиатуры числам e, f и g будет вычислять...

0 голосов
53 просмотров

Напишите программу, которая по введённым с клавиатуры числам e, f и g будет вычислять значение коэффициентов a,b и c квдратного уравнения по предлагаемым формулам, а также значение дискриминанта D, решать это квадратное уравнение и выдавать результаты его решения. a=|e-f|(|e-f| - в третьей степени) b= корень из (3e + 17)(3e+17 - в четвёртой степени) c=(g-f): 144, где D=b(в квадрате) - 4ac, корни уравнения x1,2=(-b+- корень изD): 2a отладьте программу на следующем примере: e=2 f=-2 g=3 a=64 b=529 c=0,0347222 d=279832 x1=-6<53267E-05 x2=-8,26556


Информатика (12 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

var a,b,c,D,x1,x2:real;

e,f,g:integer;

begin

writeln("vvedite koefficienty: ");

read(e);

read(f);

read(g);

a:=sqr(abs(e-f))*abs(e-f);

b:=sqr(sqr(sqrt(3*e+17)));

c:=(g-f)/144;

D:=sqr(b)-4*a*c;

x1:=(-b+sqrt(d))/(2*a);

x1:=(-b-sqrt(d))/(2*a);

writeln("x1=",x1,"x2=",x2);

readln

end.

(172 баллов)