Напишите программу поиска максимального элемента в числовом массиве из 30 различных...

0 голосов
134 просмотров

Напишите программу поиска максимального элемента в числовом массиве из 30 различных элементов.


Информатика (24 баллов) | 134 просмотров
0

какой язык?

0

???

0

Pascal

Дан 1 ответ
0 голосов
#include
#include
#include
using namespace std;

int main()
{
    srand (time(0));
    int a[30];
    for (int i=0; i<30; i++)</em>
    {
        a[i]=rand()%30+1;
        cout <<a[i] <<' ';</em>
    }
    cout <<endl;</em>
    int max = 0;
    for (int i=1; i<30; i++)</em>
      max = (a[i]>a[max]) ? i:max;
    cout <<a[max] <<endl;</em>
    return 0;
}
(2.8k баллов)