Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет...

0 голосов
48 просмотров

Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия:
а) Четные числа делит на 2 и результат выводит на экран
б) нечетные числа выводит на экран без изменений


Информатика (15 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
begin
read(a,b,c);
if odd(a) then write(a,' ')
else write(a/2,' ');
if odd(b) then write(b,' ')
else write(b/2,' ');
if odd(c) then write(c,' ')
else write(c/2,' ');
end.

(4.7k баллов)