Написать программу ** Pascal ABC. Дано предложение. Вывести строку в обратном порядке....

0 голосов
93 просмотров
Написать программу на Pascal ABC. Дано
предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы
"и", стоящие на четных местах.





Информатика (51 баллов) | 93 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  str : string;
  i, count : integer;
begin
  {часть 1 - обратный порядок}
  write('Введите строку: ');
  readln(str);
  write('Результат: ');
  for i := length(str) downto 1 do
    write(str[i]);
  {часть 2 - считаем "и"}
  count := 0;
  for i := 1 to length(str) do
    if (str[i] = 'и') and (i mod 2 = 0) then
      count := count + 1;
  writeln;           {переходим на следующую строку}
  for i := 1 to count do
    writeln('и');
end.

(918 баллов)