Даны числа x,y и z. Составьте программу, которая возводит в квадрат те из них, которые не...

0 голосов
73 просмотров

Даны числа x,y и z. Составьте программу, которая возводит в квадрат те из них, которые не отрицательные


Информатика (19 баллов) | 73 просмотров
Дан 1 ответ
0 голосов

Var
  x, y, z : real;
begin
  read (x, y, z);
  if (x > 0) then x := sqr (x);
  if (y > 0) then y := sqr (y);
  if (z > 0) then z := sqr (z);
  write (x, ' ', y, ' ', z);
end.

(4.6k баллов)