Помогите пожалуйста!!!!Напишите программу ** языке Паскаль через цикл repeat, которая...

0 голосов
38 просмотров

Помогите пожалуйста!!!!
Напишите программу на языке Паскаль через цикл repeat, которая вычисляет сумму:
а)первых n натуральных чисел
б)квадратов первых n натуральных чисел
в)всех чётных чисел в диапазоне от 1 до n
г)всех двузначных чисел


Информатика (105 баллов) | 38 просмотров
0

программа а) - должна вычислять сумму первых N чисел.Просит "введи N", ввожу 10.Выдаёт результат 17, должно быть 55(я уже не говорю о том, что там два цикла repeat, непонятная переменная А и т.д.)программа б) - должна вычислять сумму КВАДРАТОВ первых N чисел.Просит "введи N", ввожу 10Выдаёт результат 85, должно быть 385С программой в) ты, я вижу, уже сам разобрался, молодец

0

но на мой вопрос ты так и не ответил: отмеченные нарушения - это месть?

0

"определяет, натуральное ли число" - как? ты ведь описал их, как integer, достаточно проверить, не отрицательное ли оно, и всё.

0

ФВС, принимается :) Ты молодец - уважаю тех, кто умеет признать свою неправоту

Дан 1 ответ
0 голосов
Правильный ответ

Program A_1;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i;
  until i=n;
  writeln('Сумма чисел от 1 до ',n,' равна ',sum);
end.

Program B_2;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i*i;
  until i=n;
  writeln('Сумма квадратов чисел от 1 до ',n,' равна ',sum);
end.

Program V_3;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    if (i mod 2 = 0) then sum:=sum+i;
  until i=n;
  writeln('Сумма чётных чисел в диапазоне от 1 до ',n,' равна ',sum);
end.

Program G_4;
uses crt;
Var
  i,n,sum: integer;
begin
  i:=9;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i;
  until i=99;
  writeln('Сумма всех двузначных чисел равна ',sum);
end.

(52.6k баллов)