Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в...

0 голосов
96 просмотров

Информатика pascal abc
Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х<0 у=2х<br> 10.напишите программу вычисления функций у=х^2,если -2<=х<=2,у=4 в остальных случаях.<br> 11.напишите программу вычисления суммы q и w,если q>w,в противном случая их разность


Информатика (43 баллов) | 96 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,y:real;
begin
write('Введите х: ');
readln(x);
if x<0 then y:=1/x else y:=2*x;<br>writeln('y=',y)
end.

var x,y:real;
begin
write('Введите х: ');
readln(x);
if (-2<=x) and (x<=2) then y:=x*x else y:=4;<br>writeln('y=',y)
end.

var q,w,x:real;
begin
write('Введите q и w: ');
readln(q,w);
if q>w then x:=q+w else x:=q-w;
writeln('x=',x)
end.