С клавиатуры вводятся 2 числа : возраст брата и возраст сестры . Программа должна...

0 голосов
42 просмотров

С клавиатуры вводятся 2 числа : возраст брата и возраст сестры . Программа должна ответить , кто из них старше .

Дополнительно : в ответе программы должно быть сказано на сколько лет .

Вторая задача :

признак существования треугольника: каждая его сторана должна быть меньше суммы двух других . Написать программу , которая, получив с клавиатуры значения сторон треугольника a, b, c отметит , можно ли построить такой треугольник или нет .

Помагите пожалуйста написать 2 программы . Срочно !!! Заранее спасибо


Информатика (22 баллов) | 42 просмотров
0

На языке програмирования паскаль

Дан 1 ответ
0 голосов

1)
var x,y:ineger;
begin
readln(x,y);
if x>y then wrietln('X starshe Y na', x-y) else writeln('Y starhe X na ',y-x);
readln;
end.

2)
var a,b,c:integer;
begin
if a+b>c then
begin
if (a+c>b) and (b+c>a) writeln('Treygolnik')
else writeln('Error');
end
else writeln('Error');
end.

(1.1k баллов)