Напишите программу,которая получает день,номер месяца и выводит кол-во дней,оставшихся до...

0 голосов
167 просмотров

Напишите программу,которая получает день,номер месяца и выводит кол-во дней,оставшихся до нового года)))Помогите пожалуйста!!!!!


Информатика (24 баллов) | 167 просмотров
0

В паскале,английскими буквами)

0

Паскаль ABC,free

Дан 1 ответ
0 голосов
Правильный ответ

Var
 d,m,i,all:integer;
begin
 read(d,m);
 all:=0;
 for i:=12 downto (m+1) do
 begin
  if i=12 then
   all:=all+31;
  if i=11 then
   all:=all+30;
  if i=10 then
   all:=all+31;
  if i=9 then
   all:=all+30;
  if i=8 then
   all:=all+31;
  if i=7 then
   all:=all+31;
  if i=6 then
   all:=all+30;
  if i=5 then
   all:=all+31;
  if i=4 then
   all:=all+30;
  if i=3 then
   all:=all+31;
  if i=2 then
   all:=all+28;
  if i=1 then
   all:=all+31;
 end;
 if i=12 then
   all:=all+31-d;
  if i=11 then
   all:=all+30-d;
  if i=10 then
   all:=all+31-d;
  if i=9 then
   all:=all+30-d;
  if i=8 then
   all:=all+31-d;
  if i=7 then
   all:=all+31-d;
  if i=6 then
   all:=all+30-d;
  if i=5 then
   all:=all+31-d;
  if i=4 then
   all:=all+30-d;
  if i=3 then
   all:=all+31-d;
  if i=2 then
   all:=all+28-d;
  if i=1 then
   all:=all+31-d;
 writeln(all);
end.

(517 баллов)
0

24 + - )