Написать программу которая выводит ** экран числа 897, 910, 923, 936,948, 961 сначала в...

0 голосов
46 просмотров

Написать программу которая выводит на экран числа 897, 910, 923, 936,948, 961 сначала в столбик, а потом в строку.(Pascal)


Информатика (16 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

Program pr_3;
Var n:integer;
Writeln('Введите значения');
readln(n);
case n of
1:Writeln('897');
2:Writeln('910');
3:Writeln(923'');
4:Writeln('936');
5:Writeln('948');
6:Writeln('961');
readln;
end;
degin
case n of
1:Write('897');
2:Write(' ');
3:Writeln('910');
4:Write(' ');
5:Write(923'');
6:Write(' ');
7:Write('936');
8:Write(' ');
9:Write('948');
10:Write(' ');
11:Write('961');
end.
так попробуй

(26 баллов)
0

в начале уже какая то ошибка(

0

Хотя , смотря на твоё решение , я свою ошибку нашёл!) Так что спс

0

попробуй 2 цикл case of убрать вообще!

0

я вообще так сейчас сделал. var k:integer;
var i:integer;
begin
readln(k);
for i:=1 to 4 do begin
k:=13+k;
write(k, ' ');
end;
for i:=5 to 5 do begin
k:=12+k;
write(k, ' ');
end;
for i:=6 to 6 do begin
k:=13+k;
write(k, ' ');
End;
end.