Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента...

0 голосов
376 просмотров

Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно), влево на R элементов.


Информатика (22 баллов) | 376 просмотров
0

Циклический сдвиг - это как?

0

Допустим есть: 1 2 3 4 5 6

0

Говорю: с 3-го по 5-й на 1

0

Получится: 1 3 4 5 0 6 Так? Или не так?

0

в примере так написано: дано 1 2 3 4 5 6, со 2 по 5 на 2 эл.(R) и получается 1 4 5 2 3 6

0

Понятно

Дан 1 ответ
0 голосов

Var
   i,k,m,r,p,j:integer;
   a:array[1..10]of integer;
begin
writeln('Массив: ');
for i:=1 to 10 do
  begin
  a[i]:=random(10);
  write(a[i],' ');
  end;
writeln;
write('Введите K,M,R: ');
readln(k,m,r);
for i:=1 to r do
  begin
  j:=k;
  p:=a[j];
  while j    begin
    a[j]:=a[j+1];
    j:=j+1
    end;
  a[j]:=p;
  end;
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i],' ');  
end.