Написать программу в Pascal. Найти сумму 10 нечетных чисел.

0 голосов
78 просмотров

Написать программу в Pascal. Найти сумму 10 нечетных чисел.


Информатика (153 баллов) | 78 просмотров
Дан 1 ответ
0 голосов

Program fofgogjoj;
Var a: array [1..100] of integer;   
i, n, s: integer;
Begin 
s:=0;
n:=19; 
for i:=1 to n do   
begin   
a[i]:=i;           
if i mod 2=1 then s:=s+a[i];   
end; 
Writeln ('Сумма 10ти нечетных чисел равна: ',s);
End.

(856 баллов)
0

это с массивом

0

находит сумму первых десяти нечетных чисел

0

Мы массив еще не прошли. А если без него.

0

минуту

0

Program fofgogjoj;
Var
i,s: integer;
Begin
s:=0;
for i:=1 to 19 do
begin
if i mod 2=1 then
s:=s+i;
end;
Writeln ('Сумма 10ти нечетных чисел равна:',s);
End.

0

вот так без массива