Написать программу pascal, которая меняет местами последние две цифры в записи числа....

0 голосов
23 просмотров
Написать
программу pascal, которая меняет местами последние две цифры в записи числа.
Рассматриваются числа в диапазоне от m до n, причем m>99. Вывести на экран два столбика значений: первый – исходное
число, второй – измененное.

Информатика (34 баллов) | 23 просмотров
Дан 1 ответ
0 голосов

Uses crt;
var i,n,m: integer;
begin
     write('Введите число, большее 99: ');
     readln(n);
     clrscr;
     for i:=100 to n do
         writeln(i,' ',i div 100,i mod 10,i mod 100 div 10);
end.     

(7.2k баллов)