Написать программу для ПаскальНайдите среднюю температуру для дней, когда температура...

0 голосов
22 просмотров

Написать программу для Паскаль

Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. Программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.


Информатика (14 баллов) | 22 просмотров
Дан 1 ответ
0 голосов
var
  m, k, d1: single;
  i, t, d: byte;

begin
  readln(t);
  writeln();
  for i := 1 to t do
  begin
    readln(k);
    if (k > 0) then
    begin
      d1 += k;
      d  += 1;
    end;
  end;
  writeln(d1 / d);
end.
(16.9k баллов)