Написать программу в паскале:1.Удвоить заданное число, если оно положительное, утроить...

0 голосов
84 просмотров

Написать программу в паскале:1.Удвоить заданное число, если оно положительное, утроить его, если оно отрицательно, и увеличит его на 1, если оно равно нулю.


Информатика (38 баллов) | 84 просмотров
Дан 1 ответ
0 голосов

Var a:real;
begin
readln(a);
if a>0 then a:=a*2;
if a<0 then a:=a*3;<br>if a=0 then a:=a+1;
writeln(a)
end.