Написать программу pascal и excel, которая находит длину самого длинного слова в строке.

0 голосов
103 просмотров
Написать
программу pascal и excel, которая находит длину самого длинного слова в строке.

Информатика (34 баллов) | 103 просмотров
Дано ответов: 2
0 голосов

Pascal:

var s,s1,s2,max:string;
i,k,maxdl,j:integer;
begin
readln(s);
s1:=concat(s,' ');
s2:=s;
maxdl:=0;
while pos(' ',s1)>0 do begin
max:=copy(s1,1,pos(' ',s1)-1);
delete(s1,1,pos(' ',s1));
 if maxdlend;
if length(max)>maxdl then maxdl:=length(max);
writeln(maxdl);
end.


P.s. немножко криво написано)) но работает.

(822 баллов)
0 голосов

Вариант с VBA Excel
Чтобы увидеть программу жмите Alt+F11


Скачать вложение Excel (XLS)
(18.0k баллов)