Помогите пожалуйста составить программу ** языке программирования Паскаль дан двухмерный...

0 голосов
32 просмотров

Помогите пожалуйста составить программу на языке программирования Паскаль

дан двухмерный массив целых чисел.Определить сумму тех элементов массива,сумма индексов которых равна s


Информатика (28 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

Var i,j,s,g: integer; a: array [1..5,1..5] of integer;

Begin

// считываешь массив и "s"

For i:=1 to 5 do

 for j:=1 to 5 do

  If i+j=s then g:=g+a[i,j];

Writeln(g)

End.

(1.7k баллов)