Написать программу в Pascal ABC используя операторы цикла WHILE...DO и...

0 голосов
62 просмотров

Написать программу в Pascal ABC используя операторы цикла WHILE...DO и REPEAT...UNTIL:заменить последний элемент массива минимальным (размерность массива =10)


Информатика (1.0k баллов) | 62 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  A: array [1..10] of integer;
min,i:integer;
begin
i:=1
while i<11 do<br>begin
readln(A[i]);
i:=i+1;
end;
i:=1;
n:=A[1];
repeat
if min>A[i] then 
min:=A[i]
i:=i+1;
until I=10;
A[10]:=min;
end


(134 баллов)
0

программа не выводит на экран результат!

0

перед последней строчкой добавьте:

While I<11 do

0

i:=1;
While i<11 do<br>begin
Write(A[i],' ');
i:=i+1;
end: