Напишите программу в Паскале по условию Даны действительные числа x,y. Если х,у...

0 голосов
44 просмотров

Напишите программу в Паскале по условию

Даны действительные числа x,y. Если х,у отрицательны, то каждое значение заменить его модулем; если отрицательное только одно из них, то оба значения увеличить на 27; если оба значения не отрицательны, то оба значения уменьшить на 20.


Информатика (120 баллов) | 44 просмотров
Дан 1 ответ
0 голосов

Var x,y:real;
begin
read (x,y);
if (x<0) and (y<0) then writeln (abs(x),' ',abs(y)) else<br>if ((x<0) and (y>=0)) or ((y<0) and (x>=0)) then writeln (x+27,' ',y+27) else
if (x>=0)and (y>=0) then writeln (x-20,' ',y-20);
end.