4. Точка А задана координатами X,Y. Написать программу, которая выводит слово...

0 голосов
167 просмотров

4. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если
точка принадлежит заштрихованной области
(см. рисунок 4) и «Не принадлежит»
в противном случае. Программа должна иметь дружественный интерфейс. Протестировать
программу для точек (0,0), (1,0), (1.5,1),
(-1,1.5), (-2,-1), (2,-1), (1,-1), (-1,1).

Рис. 4()

заранее спасибо) отмечу как лучший





Информатика (86 баллов) | 167 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var  
   x,y : integer;

begin

  Writeln('Введите координаты x: ');
  Read(x);
  Writeln('Введите координаты y: ');
  Read(y); 
  if (x>2) or (x<-2) then<br>      Writeln('Принадлежит') else Writeln('Не принадлежит');

end.

(170 баллов)