Написать программу, вычисляющую сумму первых 10 нечётных целых чисел. Заранее спасибо.

0 голосов
37 просмотров

Написать программу, вычисляющую сумму первых 10 нечётных целых чисел. Заранее спасибо.


Информатика (105 баллов) | 37 просмотров
0

Program Pr(номер или название проги);

0

ща кароч

Дан 1 ответ
0 голосов
Правильный ответ

Program prog;
var a,i,s:integer;
begin
s:=0;
writeln('Укажите начало отрезка ');
readln(a);
for i:=a to a+10 do begin
if a mod 2 = 1 then
s:=a+s;
end;
write('Сумма нечетных 10 элементов начиная с ',a,' равна ',s);
end.

(237 баллов)
0

я тут опечатку допустил в строке

0

if a mod 1 = 0 then
замените строку на if a mod 2 = 1 then