Написать программу которая складывает числа до тех пор пока не получится число состоящее...

0 голосов
60 просмотров

Написать программу которая складывает числа до тех пор пока не получится число состоящее из одной цифры.
пример:
5+5+5=15=1+5=6
он должен ответ складывать так как показано в примере как это сделать я не как не могу понять(


Информатика (14 баллов) | 60 просмотров
0

в паскале надо написать

Дан 1 ответ
0 голосов

Var
  a, b: integer;

begin
  readln(a);
  while (inttostr(a).Length > 1) do
  begin
    b := 0;
    foreach c: char in inttostr(a) do
      b += strtoint(c);
    a := b;
  end;
  writeln(b);
end.
=======================
var
  a, b, e: integer;
  d: string;

begin
  readln(a);
  d := inttostr(a);
  while (length(d) > 1) do
  begin
    d := inttostr(a);
    b := 0;
    for e := 1 to length(d) do
      b += strtoint(d[e]);
    a := b;
  end;
  writeln(b);
end.

(16.9k баллов)
0

ясно спасибо за это

0

Ладно, сейчас перепишу

0

хорошо буду очень благодарен

0

Вот

0

спасибо щяс попробую

0

спасибо но всеравно выдает ошибку там где inttostr именно это ему ненравится

0

я поробовал в абс все работает

0

который первый программный код

0

inttostr пишет unknown identifier

0

Странно, даже в турбо должно работать