Паскаль! Срочно!1)Написать программу, которая из заданного одномерного массива...

0 голосов
91 просмотров

Паскаль! Срочно!
1)Написать
программу, которая из заданного одномерного массива размерности
N выводит
только те элементы, значения которых принадлежат отрезку [
c,d].
2)
Дан
массив действительных чисел
B[N]. Сформировать из него новый массив C[N],
выбросив из него максимальные элементы.
Пример

Массив B: 2 3 5 8 5 2 8 5 4 8


Массив C: 2 3 5 5 2 5 4


Информатика (140 баллов) | 91 просмотров
Дан 1 ответ
0 голосов

1)  var i,n:integer;
     c,d:integer;
     a:array[1..1000] of integer;
    begin write('введите c,d,n');
read(c,d,n);
for i:=1 to n do begin
a[i]:=random(100);
write(a[i],' ');
end;
for i:=1 to n do begin
if (a[i]>=c) and (a[i]<=d) then write(a[i],' ');<br>end;
end.
2) по ссылке на файл

(20.8k баллов)
0

Опять ссылки нет

0

проверьте в сообщениях

0

В моих сообщениях?! Ты решение только автору вопроса высылаешь?