Помогите!:с нужно составить алгоритм ** языке программирования Паскаль. Дан массив,...

0 голосов
39 просмотров

Помогите!:с нужно составить алгоритм на языке программирования Паскаль.
Дан массив, состоящий из 10 элементов. Определите, сколько элементов этого массива имеют максимальное значение.


Информатика (115 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Var a:array[1..10] of real;
b,c:integer;
max:real;
begin
c:=0;
writeln('Введите элементы массива');
for b:=1 to 10 do
begin
readln(a[b]);
end;
max:=a[1];
for b:=1 to 10 do
begin
if a[b]>max then max:=a[b];
end;
for b:=1 to 10 do
begin
if a[b]=max then c:=c+1;
end;
writeln('Количество элементов,имеющих максимальное значение равняется ',c);
end.

(13.4k баллов)
0

большое спасибо!)

0

Пожалуйста