Привет!Очень срочно!!!Написать программу и блок -схему для вычисления площади кольца,...

0 голосов
46 просмотров

Привет!Очень срочно!!!Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения площади круга: S=pi *R^2


Информатика (17 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
procedure MinMax(var min, max: real);
var
  a: real;
begin
  if (min > max) then
  begin
    a := min;
    min := max;
    max := a;
  end;
end;

var
  r1, r2: real;
begin
  readln(r1, r2);
  r1 := pi * sqr(r1);
  r2 := pi * sqr(r2);
  MinMax(r1, r2);
  writeln('S = ', r2 - r1);
end.
image
(16.9k баллов)
0

Спасибо большое!!!