Нужно написать программу ** С++условие:Дана строка, состоящая из заглавных и маленьких...

0 голосов
43 просмотров

Нужно написать программу на С++
условие:


Дана строка, состоящая из заглавных и маленьких
латинских букв. Заменить все заглавные буквы на соответствующие маленькие и
вывести строку.


Информатика (16 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

#include
#include

int main()
{
 std::string str;
 std::cin >> str;

 for (int i = 0; i < str.size(); i++)
 {
  if (int(str[i]) < int('a'))
 {
 str[i] = str[i] + 32;
 }
 std::cout << str[i];</span>
 }

 std::cout << std::endl;</span>
 system("pause");
 return 0;
}

(404 баллов)