Помогите написать программу в Паскале и блок-сxему.Задача: ввести 10 чисел, если число...

0 голосов
60 просмотров
Помогите написать программу в Паскале и блок-сxему.
Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число отрицательное, то ничего с ним не делать. Вывести результат на экран.

Информатика (12 баллов) | 60 просмотров
Дан 1 ответ
0 голосов

Var a,b,i: real;
begin
b:=0,5;
for i = 1 to 10 do
begin
readln (a);
if a<0 then<br>writeln (a)
else
a:=a-b;
writeln (a);
end;
end.

(1.2k баллов)
0

наверно так

0

спасибо

0

Спасибо, что подправил, а то я паскалю самообучаюсь и могу делать мелкие огрехи))

0

Аналогично))

0

Большое вам спасибо!!!)