Это программирование, паскаль, нужно написать программу Дан одномерный массив A,...

0 голосов
48 просмотров

Это программирование, паскаль, нужно написать программу










Дан одномерный массив A, состоящий из N элементов, N – заданное натуральное
число. Если элементы массива составляют строго монотонную последовательность, то
все положительные элементы массива заменить единицей, иначе оставить массив без
изменения.






Информатика (77 баллов) | 48 просмотров
0

Это задание полное, ув. товарищ админ

Дан 1 ответ
0 голосов
Правильный ответ

A:array[1..30000] of integer;
n, i, k, z:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if (a[i]for i:=1 to n do
if (a[i]>a[i+1]) then z:=z+1;
if (k=n) or (z=n) then
for i:=1 to n do
if a[i]>0 then a[i]:=1;
for i:=1 to n do
writeln(a[i]);
readln;
end.

0

если не будет работать попробуйте (k=n) or (z=n) then begin и end после a[i]:=1;