Надо составить программу в Паскальв конце я не уверенна, надо как то по другому соединить...

0 голосов
53 просмотров

Надо составить программу в Паскаль
в конце я не уверенна, надо как то по другому соединить их ....
ПОМОГИТЕ,ПОЖАЛУЙСТА... ОЧЕНЬ НАДО


image

Информатика (393 баллов) | 53 просмотров
0

если бы я знала

0

тогда сложно что-либо написать..

0

это блок-схемы, они описывают содержание программы.

0

а может и их кол-во.. не знаю я

0

предполагаю, что сами числа

0

вобще нам сказали, что программу надо составлять по этой фигня, которая в приложении

0

Вывести сами числа или их количество?

0

ну в роде того

0

это и есть условие) то есть найти числа кратные и 5, и 13 одновременно?

0

все что нам дал учитель это: найти числа кратные 5,13... xmod5=0, xmod13=0

Дан 1 ответ
0 голосов

Var x: integer;
Begin
Read (x);
If x mod 5 = 0 and x mod 13 = 0 then
Write(x);
end.

(512 баллов)
0

program n_5;
Var x: integer;
Begin
Read (x);
If x mod 5) = 0 then
x кратно 5 else
if x mod 13=0 then
x кратно 5 else
левое число
Write(x);
end.

0

не работает

0

Program1.pas(5,4): Операция '=' не применима к типам integer и boolean

0

Var x: integer;
Begin
Read (x);
If x mod 5 = 0 and x mod 13 = 0 then
Write(x);
end. должно работать!

0

я не понимаю как надо правильно её составить

0

учитель сказал, а мне все равно

0

а что за "левое число"? Ты в программе так и пишешь - "кратно"?)

0

надо типо того, только правильно составить

0

else не обязательно.

0

я только что запускал эту программу. Всё работает.