Помогите написать программу о загрузке самолета

0 голосов
41 просмотров

Помогите написать программу о загрузке самолета


Информатика (12 баллов) | 41 просмотров
0

нет

0

ПРОГРАММУ НА PASCAL, ну например загрузку пасажиров в самолет

0

Извините уважаемый, но к сожалению я сама не знаю точной информации о загрузке

0

Так как в задаче прописаны только те условия, которые я вам написала.

0

И как я понимаю, то наверное здесь не имеет значения сколько пассажиров или груза, так как число этих "грузов" может иметь N количество

Дан 1 ответ
0 голосов

Люблю нерешаемые задачи, в них исключения не надо проверять:)

uses

  AirplaneAPI;

var
  AP: Airplane;
  sBuf: string;

begin
  AP := new Airplane(Types.Boeing747, 'N752PA');
  writeln('Пустая строка - конец посадки пассажиров');
  repeat
    writeln('Номер билета: ');
    readln(sBuf);
    if not Ticket.Verify(sBuf) then
      writeln('| Неверный номер билета. Код ', Ticket.LastCode, ' |')
    else
      AP.Pass.Add(Ticket.getInfo(sBuf));
    if ((sBuf.Length = 0) or (AP.Loaded)) then
      break;
  until (false);
  writeln('Самолёт загружен');
end.

(16.9k баллов)