Срочно!!! написать программу в паскаль.Дан массив целых чисел, состоящий из 20 элементов....

0 голосов
22 просмотров

Срочно!!! написать программу в паскаль.
Дан массив целых чисел, состоящий из 20 элементов. Заполнить его датчиком случайных чисел. Заменить максимальный элемент на противоположный по знаку.


Информатика (24 баллов) | 22 просмотров
0

Ставь Лутшее решение за решение (необходимо)

Дан 1 ответ
0 голосов
Правильный ответ

Program chik;
const n=20;
var a:array[1..20]of integer;
i,l,max:integer;
begin
randomize;
for i:=1 to n do
a[i]:=random(100)-50;
max:=a[1];
for i:=2 to n do
if(a[i]>max)then max:=a[i];
for i:=1 to n do
begin
if(a[i]=max)then a[i]:=-max;
write(a[i],' ');
end;
end.

(6.6k баллов)