Помогите написать программу паскаль, которая формирует массив, элементами которого...

0 голосов
43 просмотров
Помогите написать программу паскаль, которая формирует массив, элементами которого являются цифры заданного натурального числа.

Информатика (34 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
var
  a: array of byte; //char?
  b, d: integer;

begin
  readln(b);
  SetLength(a, length(IntToStr(b)));
  
  for d := 0 to length(a) - 1 do
  begin
    a[d] := b mod 10;
    b := b div 10;
  end;
  
  for d := 0 to (length(a) - 1) do
    write(a[d], ' ');
end
(16.9k баллов)