С++ Помогите написать программу перевода из десятичного числа в двоичное.

0 голосов
75 просмотров

С++

Помогите написать программу перевода из десятичного числа в двоичное.


Информатика (20 баллов) | 75 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

void bin(int n);
int main()
{
    int n;
    cout<<"Введи число в десятичной системе счисления\n";<br>    cin>>n;
    bin(n);
    system("pause");
    return 0;
}

void bin(int n)
{
     int binn[15], ;
     for(int i=14;i>=0; i--)
     {
             binn[i]=n % 2;
             n=n/2;
             }
    
     for(int i=0; i<=14;i++)<br>     {
             cout<<binn[i];<br>             }
      cout<<"\n";       <br>}            

(1.3k баллов)