Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол....

0 голосов
157 просмотров
Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. Количество очков, полученных командами в ходе игры, может быть равно 1, 2 или 3. После окончания игры выдать итоговое сообщение и указать номер команды-победительницы. Окончание игры условно моделировать вводом количества очков, равного нулю. На паскаль

Информатика (22 баллов) | 157 просмотров
0

щас напишем

0

varn,r,i,k1,k2,r1:integer;beginreadln(n); //‘Є®«мЄ® а § Ўг¤гв ЁЈа вмfor i:=1 to n dobeginr:=random(2)+1;case r of1:beginr1:=random(2)+1;writeln('1 Komanda zabila',r1);k1:=k1+r;end;2:beginr1:=random(2)+1;writeln('2 Komanda zabila',r1);k2:=k2+r;end;3:beginr1:=random(1)+1;writeln('Komanda ',r1,' Pochti zabila no Promax(((');

0

end;end;end;if k1>k2 thenbeginWriteLn('1 Komanda WIN ',k1);end;if k2>k1 thenbeginwriteln('2 Komanda WIN ',k2);end;if k1=k2 then writeln('Pobedila Drijba ',k1);end.

Дано ответов: 2
0 голосов
var
  commands: array [1..2] of byte;
  buf: string;

begin
  writeln('Формат ввода: (№ комманды)(пробел)(очки)');
  writeln('Например:     1 3');
  writeln('№ О');
  repeat
    readln(buf);
    if buf = '0' then break;
    commands[integer.Parse(buf[1])] += byte.Parse(buf[3]);
  until false;
  
  writeln(String.Format('Команда {0} победила во счётом {1} очк.', commands[1] > commands[2] ? 1 : 2, max(commands[1], commands[2])));
end.
(16.9k баллов)
0 голосов

Полный код не влез, в 2 комента вставил

(528 баллов)