Определить попадает ли точка в заданный диапазон. Написать программу.Pascal

0 голосов
101 просмотров
Определить попадает ли точка в заданный диапазон. Написать программу.Pascal


image

Информатика | 101 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
    x, y, r: real;

begin
    read(x, y, r);
    if ((x >= 0) and (y >= 0) and (x * x + y * y <= r * r)) <br>        or ((x < 0) and (y < 0) and (x + y >= -r)) then
        write('да')
    else
        write('нет');
end.

(53.1k баллов)
0

не верно у вас, например точка -0.8 -0.1 r=1 (в зону попадает), а у вас нет

0

или вам просто надо чтоб этих if было много? это конечно можно сделать, но смысла никакого, только больше писать придется

0

ну так и есть одно если, этого достаточно. задача правильная

0 голосов

Var x,y,r:real;
begin
read(x,y,r);
if (x>=0) and (y>=0) and (x^2+y^2<=r^2) and (x<=0) and (y<=0) and (x+y>= -r) then write('попадает') else write('нет');
end.

(20.8k баллов)
0

квадраты в паскале так не пишутся