Напишите программу которая вычислит площадь геометрических фигур в Паскале.....1)Круг...

0 голосов
87 просмотров

Напишите программу которая вычислит площадь геометрических фигур в Паскале.....1)Круг 2)прямоугольник 3)квадрат 4)паралеллограм


Информатика (70 баллов) | 87 просмотров
Дан 1 ответ
0 голосов

1) по заданному радиусу:

 

Program n1;
Uses CRT;
Var r,s: real;
begin
ClrScr;
writeln('Vvedite radius');
readln(r);
s:=r*r*pi;
Writeln('ploshad =',s:4:4);
readln
end.

 

2) по заданным сторонам:

Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storoni');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end.

 

3) по заданной стороне

Program n1;
Uses CRT;
Var a,s: real;
begin
ClrScr;
writeln('Vvedite storony');
readln(a);
s:=a*a;
Writeln('ploshad =',s:4:4);
readln
end.

 

3) по одной стороне и высоте к ней:

Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storony i vysoty k nei');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end.

(1.7k баллов)