Написать программу для турбо паскаля. Условие: По 3 введеным сторонам треугольника...

0 голосов
53 просмотров

Написать программу для турбо паскаля.
Условие:
По 3 введеным сторонам треугольника определить является ли треугольник прямоугольным.


Информатика (27 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

PROGRAM TREUG;
var a,b,c: integer;
begin
writeln ('Сторона 1=');
readln (a);
writeln ('Сторона 2=');
readln (b);
writeln ('Сторона 3=');
readln (c);
if ((a^2=b^2+c^2)or(b^2=a^2+c^2)or(c^2=a^2+b^2)) then
writeln ('треугольник прямоугольный');
else writeln ('треугольник не прямоугольный');
end.

(832 баллов)