Помогите выполнить задание по ИКТ!! ** программу Паскаль Написать программу подсчета...

0 голосов
50 просмотров

Помогите выполнить задание по ИКТ!! на программу Паскаль
Написать программу подсчета количества элементов, если индекс ячейки нечетное число, а элемент ячейки-чётное


Информатика (77 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  i,n:integer;
  a:array[1..20]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 20 do
  begin
  a[i]:=random(10);
  if (i mod 2=1) and (a[i] mod 2=0) then n:=n+1;
  write(a[i],' ');
  end;
writeln;
writeln('Искомых элементов: ',n);
end.