Язык С !!! срочно КУЧУ БАЛЛОВ ДАЮ!!! Составить программу, которая по формулам для...

0 голосов
45 просмотров

Язык С !!! срочно КУЧУ БАЛЛОВ ДАЮ!!!
Составить программу, которая по формулам для арифметической
прогрессии находит сумму n первых элементов прогрессии и значения
трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и
разность прогрессии вводятся пользователем. Вывести значения
элементов в форме таблицы, где первая строка – номер, а вторая –
значение.


Информатика (328 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
#include "stdafx.h"
#include "windows.h"
#include "locale.h"

int main(){
setlocale(0, "");

int n, a1, d, sum, A1, A2, an;

printf("Введите первый элемент прогрессии  \n");

scanf_s("%i", &a1);

printf("Введите число элементов геометрической прогрессии \n");

scanf_s("%i", &n);

printf("Введите разность арифметической прогрессии \n");

scanf_s("%i", &d);

sum = ((2 * a1 + d*(n - 1)) / 2)*n;

an = a1 + d*(n - 1);

A1 = an - d;

A2 = an + d;

printf("Номер      An-1   An   An+1   sum \n");

printf("Значение   %i      %i    %i    %i \n", A1, an, A2, sum);

system("pause");

return 0;
}
(236 баллов)
0

И вот исправленный код

0

Да я-то знаю, но Вы же пишете ответ для человека на С

0

#include "stdafx.h"
#include "windows.h"
#include "locale.h"

int main()
{
setlocale(0, "");
int n, a1, d, sum, A1, A2, an;
printf("Введите первый элемент прогрессии \n");
scanf_s("%i", &a1);
printf("Введите число элементов геометрической прогрессии \n");

0

scanf_s("%i", &n);
printf("Введите разность арифметической прогрессии \n");
scanf_s("%i", &d);
sum = ((2 * a1 + d*(n - 1)) / 2)*n;
an = a1 + d*(n - 1);
A1 = an - d;
A2 = an + d;
printf("Номер An-1 An An+1 sum \n");
printf("Значение %i %i %i %i \n", A1, an, A2, sum);
system("pause");
return 0;
}

0

Исправлять надо в ответе, а не в комментарии, иначе его удалят, ак неверное решение

0

спасибо, сейчас исправлю

0

Вот, теперь все нормально)

0

Ну и отлично =) Надеюсь, что помог

0

Спасибо...

0

Немного изменил, но в цело норм.