составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и...

0 голосов
30 просмотров

составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет среднее арифметическое нечётных чисел.

только чтобы правильно было...помогите плииз!!!!


Информатика (16 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

var

  a: array [1..40] of integer; //Инициализируем массив из 40 целых чисел

  i, s, n: integer; //s - сумма нечетных чисел, n - счетчик нечетных элементов

begin

  s:= 0;

  n:= 0;

  write('Исходный массив: ');

  for i:= 1 to 40 do 

  begin

    a[i]:= random(20); //Формируем элемент массива

    write(a[i], '  '); //Распечатываем

    if a[i] mod 2 = 1 then {если элемент нечетный, то прибавляем его значение к сумме и увеличиваем счетчик нечетных элементов на 1}

    begin

      s:= s + a[i];

      n:= n + 1;

    end;

  end;

  writeln;

  write('Среднее арифметическое: ', s / n : 0 : 5); {Делим сумму нечетных элементов на их количество и выводим с точностью до 5 знаков после запятой}

end.

(2.1k баллов)