Напишите программу нахождения НОК двух не нулевых чисел язык pascal

0 голосов
37 просмотров

Напишите программу нахождения НОК двух не нулевых чисел язык pascal


Информатика (18 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Program LeastCommonMult; var m, n, prod: word; begin readln(m, n); prod := m * n; while m <> n do begin if m > n then begin m := m - n end else begin n := n - m end end; writeln(prod div m) end.

(63 баллов)