Помогите написать программу в паскале:Даны две строки: S1 и S2. Можно ли из символов...

0 голосов
47 просмотров

Помогите написать программу в паскале:Даны две строки: S1 и S2. Можно ли из символов строки S1 составить строку S2? Регистр значения не имеет.

(например

a) S1=’april’, S2=’may’. Ответ: false

b) S1=’Rom’, S2=’room’. Ответ: false, т.к. буква ‘o’ встречается в строке S1 один раз.

c) S1=’tomorrow’, S2=’mOtOr’. Ответ: true)



Информатика (18 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Var
  i,n:integer;
  s1,s2:string;
  f:boolean;
begin
f:=true;
writeln('Введите первую строку');
readln(s1);
writeln('Введите вторую строку');
readln(s2);
s1:=LowerCase(s1);
s2:=LowerCase(s2);
i:=1;
repeat
  n:=pos(s2[i],s1);
  if n>0 then delete(s1,n,1) else f:=false;
  i:=i+1;
  until i=length(s2);
writeln(f)
end.