Ребят, помогите решить!Дано два натуральных числа N и M.Написать программу для...

0 голосов
18 просмотров

Ребят, помогите решить!
Дано два натуральных числа N и M.
Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих нулей в найденном числе быть не должно.
Формат входных данных:
Входной файл INPUT.TXT содержит два натуральных числа N (10<=N<=10^100) и M (10<=M<=10^100), разделенных одним пробелом.<br>Формат выходных данных:
Выходной файл OUTPUT.TXT должен содержать найденной наименьшее число.
Пример
INPUT.txt. OUTPUT.txt
423 42 22344


Информатика (31 баллов) | 18 просмотров
0

задание такое

0

ЛОГИКА В ТОМ ЧТО НУЖНО ДУМАТЬ, КАК С ПОМОЩЬЮ ПРОГРАММЫ ЭТО СДЕЛАТЬ, В ЖИЗНИ ТАКОЕ ВРЯДЛИ ПРИГОДИТСЯ

0

задание нормальное, всё чётко, а раз ты такой умный то напиши программу

Дан 1 ответ
0 голосов
Правильный ответ

Procedure ShellStr(var s: string);
{ сортирует символы строки методом Шелла }
var
  i, j, n, step: integer;
  c: char;
begin
  s := Trim(s);
  n := Length(s);
  step := n div 2;
  while step > 0 do
  begin
    for j := n - step downto 1 do
    begin
      i := j;
      while i <= n - step do <br>      begin
        if s[i] > s[i + step] then
        begin
          c := s[i];
          s[i] := s[i + 1];
          s[i + 1] := c
        end;
        i := i + step
      end
    end;
    step := step div 2
  end
end;

procedure TrimNullsLeft(var s: string);
{ Усекает левые (незначащие нули) в строке s }
var
  i, n: integer;
begin
  i := 1; n := Length(s);
  while (s[i] = '0') do i := i + 1;
  s := Copy(s, i, n - i + 1)
end;

var
  p: integer;
  s, M, N: string;
  f: text;

begin
  Assign(f, 'input.txt');
  Reset(f);
  Readln(f, s);
  Close(f);
  Assign(f, 'output.txt');
  Rewrite(f);
  s := Trim(s);
  p := Pos(' ', s);
  M := Copy(s, 1, p - 1);
  N := Copy(s, p + 1, Length(s) - p);
  s := M + N;
  ShellStr(s);
  TrimNullsLeft(s);
  Writeln(f, s);
  Close(f);
  Writeln('Программа завершила работу')
end.


Скачать вложение Текст (TXT)
Скачать вложение Текст (TXT)
(142k баллов)
0

а если он си изучает?

0

и код что-то очень большой