Написать программу для паскаль.С клавиатуры вводятся целые числа.Признаком конца ввода...

0 голосов
104 просмотров

Написать программу для паскаль.С клавиатуры вводятся целые числа.Признаком конца ввода является 0.Изменить знак отрицательных чисел на противоположный.Результаты вывести на экран.


Информатика (20 баллов) | 104 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var n: integer;
    s: string;
begin
    writeln('Вводите числа');
    repeat
        readln(n);
        s:= s + IntToStr(abs(n)) + ' '
    until n = 0;

    writeln(s);
end.

(53.1k баллов)
0 голосов

Предложу решение, основанное на том, что понял из текста) 

var a: integer;
begin
writeln('Вводите числа');
 a:=1;
while a<>0 do begin
readln(a);
if a<0 then writeln('Противоположное число ',abs(a));<br>end;
readln
end.

Можно их в массив записывать, если нужно вывести красиво.

(797 баллов)