Вася хочет узнать, какую оценку он получит в четверти по информатике. Учитель...

0 голосов
287 просмотров

Вася хочет узнать, какую оценку он получит в четверти по информатике. Учитель придерживается следующей системы: вычисляется среднее арифметическое всех оценок в журнале, и ставится ближайшая целая оценка, не превосходящая среднего арифметического. При этом если у школьника есть двойка, а следующая за ней оценка – не двойка, то двойка считается закрытой, и при вычислении среднего арифметического не учитывается. Входные данные Вводится десять натуральных чисел от 2 до 5 через пробел – оценки Васи. Выходные данные Выведите натуральное число (от 2 до 5) – его четвертную оценку.

входные данные:

2 5 2 5 2 5 2 5 2 5
2 2 2 2 2 2 2 2 2 5
5 5 5 5 5 5 5 5 5 2

выходные данные:

5

2

4


Информатика (12 баллов) | 287 просмотров
Дан 1 ответ
0 голосов

решение в среде Паскаль:

Var a:array[1..10] of Integer; i,s,m: integer; f,t:real;
begin
s:=0;
writeln('write marks');
For i:=1 to 10 do begin
readln(a[i]);
If i>1 then begin
If a[i-1]=2 then begin
If a[i]<>2 then begin s:=s-2; m:=m-1; end;end;end;
s:=s+a[i];
m:=m+1;
end;
f:=s/m;
t:=Int(f);
Writeln('His or her mark is ', t:2:0);
readln;
end.

(279 баллов)