Pascal нужно написать программу с алгоритмом 3.1 и 3.2 , 6 Нужно очень очень. Подробно...

0 голосов
38 просмотров
Pascal нужно написать программу с алгоритмом 3.1 и 3.2 , 6
Нужно очень очень. Подробно если можно

image
image

Информатика (67 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

3.1
var
  x, a, b, c: real;

begin
  readln(x, a, b, c);
  writeln('y = ', (sqr(a - 4) * (1 / (x * x * x)) - 3 * sqr(b) * x) / (a * x + b) + 3 * (1 / sqr(a)) - ln(x));
end.

3.2
var
  a, h, b, c: real;

begin
  readln(a, h);
  c := 2 * sqrt(sqr(a) - sqr(h));
  b := a;
  writeln('P = ', a + b + c);
  writeln('S = ', 0.5 * sqr(a));
end.

6
var
  n, t: byte;
  g: integer;

begin
  readln(n);
  for i: byte := 1 to n do
  begin
    readln(t);
    g := g + t;
  end;
  writeln(g / n:0:1, ' г.');
end.

(16.9k баллов)