Задали по информатике составить программу для a3(а в кубе).Как это сделать помогите...

0 голосов
32 просмотров

Задали по информатике составить программу для a3(а в кубе).
Как это сделать помогите пожалуйста.


Информатика | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program KUB;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите число a = ');
      readln(a);
      writeln;
      write('a^3 = ',a*a*a);

End.


ЛИБО

 write('a^3 = ',exp(3*ln(a)));
     


(9.6k баллов)
0

Вариант с логарифмом пишется немного более сложно. Под знак логарифма надо ставить модуль а. Если а было отрицательным, то результату приписать знак минус. А если a=0, надо в ответ давать 0.

0

Наиболее быстрый вариант a*sqr(a)